Microsoft Excel już od 1987 roku wspomaga użytkowników w przygotowywaniu różnego rodzaju zestawień, tabel i wyliczeń. To bardzo przydatne narzędzie, ale można dodatkowo zautomatyzować jego działanie. Wystarczy wykorzystać do tego odpowiednie formuły.
Ręczne wpisywanie bardzo wielu danych w Excelu może być bardzo żmudne, a do tego niesie za sobą niebezpieczeństwo popełnienia błędu. Na szczęście producent arkusza kalkulacyjnego przewidział taką sytuację i umożliwił zautomatyzowanie wielu działań. Służą do tego różnego rodzaju formuły. Dzięki nim można znacznie skrócić czas pracy, a do tego podnieść dokładność wprowadzanych danych oraz raportów. Wybraliśmy dla was 9 najpopularniejszych formuł, które warto często wykorzystywać w pracy z Excelem.

1. Sumowanie komórek

Sumowanie danych to jedno z podstawowych działań, wykonywanych w arkuszu kalkulacyjnym. O ile policzenie wartości kilku komórek można jeszcze przeprowadzić w miarę szybko, o tyle suma już kilkunastu lub kilkudziesięciu komórek może zabrać dużo czasu. Problem rozwiązuje prosta funkcja: =SUMA(A1;A10), =SUMA(A1:A10). W ten sposób dodaje się pojedyncze wartości, odwołanie do komórek lub zakres wyznaczonych komórek.

2. Zliczanie liczb

Często przydatna jest także funkcja, która zlicza ilość liczb występujących w określonym przez użytkownika zakresie. Wykorzystuje się do tego funkcję ILE.LICZB. Na przykład, gdy chcemy zliczyć liczby w zakresie komórek od B1 do B10, musimy ułożyć formułę =ILE.LICZB(B1:B10). Gdy w tym zakresie tylko w 8 komórkach znajdują się liczby, funkcja zwraca liczbę 8.

3. Odejmowanie komórek

Skoro omówiliśmy już formułę sumowania komórek, nie można także pominąć tak podstawowego działania matematycznego, jak odejmowanie. Gdy chcemy odjąć wartość jednej komórki od drugiej, wystarczy użyć bardzo prostej funkcji, np. =C10-C9.

Dowiedz się więcej: Kurs Excel 2013 od podstaw Zobacz kurs

4. Liczba znaków

Excel umożliwia również łatwe liczenie znaków ciągu tekstowego w komórkach. Wystarczy wybrać interesującą nas komórkę (np. A5) i wpisać formułę =DŁ(A5), która zwróci błyskawicznie liczbę znaków. Należy jednak zwrócić uwagę, że Excel zlicza także spacje pomiędzy słowami.

5. Usuwanie spacji i znaków niedrukowanych

Często zdarza się, że dane eksportowane są do Excela z bazy systemu używanego przez firmę do codziennej pracy. Wtedy mogą się tam pojawić dodatkowe spacje (wiodące, końcowe, znaki spacji), a także znaki niedrukowane. Usuwanie ich ręcznie przy dużej ilości danych zabrałoby bardzo dużo czasu, a do tego byłoby niezwykle żmudne. Z pomocą przychodzi nam jednak kolejna funkcja Excela. Jeśli wpiszemy =USUŃ.ZBĘDNE.ODSTĘPY(B2), z komórki B2 zostaną usunięte spacje, natomiast funkcja =OCZYŚĆ(B2) eliminuje z komórki niedrukowalne znaki.

6. Wyszukiwanie pionowe

Funkcja wyszukiwania pionowego to jedno z ważniejszych ułatwień pracy w Excelu, nieocenione przy analizie dużej ilości danych. Dzięki WYSZUKAJ.PIONOWO możemy znaleźć dane w całej tabeli lub w określonym zakresie wierszy. Funkcja na pozór może wydawać się bardzo skomplikowana, dlatego najlepiej pokazać jej możliwość na przykładzie. Wpisujemy =WYSZUKAJ.PIONOWO(D20;B2:E10;3;FAŁSZ). To oznacza, że funkcja znajdzie dla nas wartość wprowadzoną w komórce D20, przeszukując zakres komórek od B2 do E10, natomiast 3 to numer kolumny, która zawiera wartość zwracaną. Gdy na koniec dopiszemy FAŁSZ, wartość zwracana zostanie dokładnie dopasowana, a przy oznaczeniu PRAWDA otrzymamy wartość przybliżoną.

7. Łączenie ciągów tekstowych

Czasami bardzo przydatna okazuje się funkcja łączenia dwóch lub więcej ciągów tekstowych w jeden. Możemy tu wykorzystać różne opcje, np.: =ZŁĄCZ.TEKSTY(C2;” ”;B2) łączy tekst z komórki C2 i B2, wstawiając pomiędzy nimi spację, =ZŁĄCZ.TEKSTY(C2;", ";B2) pomiędzy złączonymi tekstami z komórek wprowadzany jest przecinek.

8. Zliczanie niepustych komórek

Możemy policzyć komórki, które zawierają dowolny typ informacji. Wystarczy użyć np. następującej funkcji: =ILE.NIEPUSTYCH( A1:A10). W ten sposób sprawdzamy zakres określonych komórek.

9. Obliczanie średniej

Jeśli chcemy obliczyć średnią dla określonej grupy liczb, wystarczy użyć formuły na przykład =ŚREDNIA(A2:A7). W tym przypadku otrzymamy średnią wartość dla liczb z wybranego zakresu komórek.

Dowiedz się więcej: Kurs Excel - zaawansowane techniki Zobacz kurs

Oczywiście wybór odpowiednich formuł powinien zależeć od tego, jaką pracę wykonujemy w Excelu i z jakich działań matematycznych korzystamy najczęściej.